Sunday, May 29, 2011

Frustrated with migrating to Rails 3...

One of the biggest frustrations with mixing dependency management and packaging in Linux is when an upgrade to one forces an upgrade to the other. Or more specifically, when upgrading to a more recent release of Fedora forces an upgrade to the version of Rails installed.

With Fedora 14 we had Rails 2.3.8. Now, with Fedora 15, we have Rails 3.0.5. And, sadly, it's not a simple task to just upgrade a Rails app since quite a bit has changed between 2.3 and 3.0. Enough that it almost feels like it would make more sense to just start over the project by creating a new Rails app and then moving the existing controllers, models, etc. over to the new app.

But that just sounds like a copout. There has to be a way to easily migrate from 2.3 to 3.0.

So guess what I'm doing this weekend?

No comments:

Post a Comment